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RELEASE SUMMARY 

CAM350/DFM 15.0 build 2073 is a minor update to the currently released CAM350 15.0 product.  

This release includes several customer defect fixes and enhancements as well as language releases 

for the Japanese and Chinese markets.  The new product features in 15.0 are described later in 

this document.   They include a new CAM350 Stencil Kit, a new Auto Align feature and a New 

Cadence Allegro interface as well as several enhancements.    

 

INSTALLATION AND LICENSING 

The installer for the client software (CAM350 15.0 and BluePrint 7.0) will create new folders and 

you can run both your previous release (CAM350 14.6 and BluePrint 6.6) and your new Release 

software side by side on the same PC if you wish.    There is a new 15.0-7.0 License Manager and 

License that must be installed.  This new License Manager and License will run your 15.0-7.0 

software as well as previous releases (ie BluePrint 6.6 and 6.5). 

 

Note:  The CAM350 15.0 – BluePrint 7.0 License Manager will NOT run CAM350 12.2 – BluePrint 

5.2 product licenses.     

 

For many users your installation should be as simple as this: 

 

1. Run the installation executable 

2. Choose “Install or Update Licensing” to install your new License Manager and License 

File. 

a. If you are an existing customer on maintenance, choose “Install license from 

media” to install your new license file. 

b. If you are a new user or your license is not found on media, get your new license 

from DownStream, copy it to your PC and then choose “browse to find License 

File”.   

3. Choose “Install DownStream Products” to install the new CAM350 15.0 and BluePrint 7.0 

software on your PC. 

 

If you are installing to a Virtual Machine or have any questions, reference our DownStream 

Installation Guide or contact us at support@downstreamtech.com. 

 

 

SYSTEM REQUIREMENTS 

Your PC should meet or exceed the following requirements: 

 

OS:  Windows 10, 11 (64 bit only) 

Processor:  2GHz or faster 

Memory:  8-16GB+ 

Disk Space:  2GB available, SDD Recommended 

Graphics:  Discrete graphics card with on-board memory preferred (for best 3D performance) 

 

 

mailto:support@downstreamtech.com
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CAM350 15.0 NEW FEATURES 

________________________________________________________________________ 
✓ New Stencil Designer 

✓ New Auto Layer Align 

✓ New Cadence Allegro Interface 

✓ Netlist Compare enhancements 

✓ Design Compare enhancements 

✓ Licensing support for Nutanix AHV Virtual Machine 

 

 

 

 

 

 

 

 

CAM350 15.0 – NEW FEATURES DETAILED 

 
NEW STENCIL DESIGNER 

Use the new Stencil Designer to create custom paste stencils sourced from paste mask, solder 

mask, Top or other layer types. Source a stencil from a selected patterns of flashes or pads or 

select a footprint. Saved the stencil definition to a stencil library and reuse defined stencils across 

multiple designs. Use the Application Programming Interface to automate the stencil design 

process. 

 

EXAMPLE A – In this example, you will use the new Stencil Designer to create stencils for a 

design using the change shape creation mode. 

1. Start CAM350 and choose File > Open. 

2. Browse to and select the demo file DST Demo 2018.cam from the Demos folder. 

3. In the Layers Display pane, double click the Paste Mask Top layer to make it the 

only visible layer. 

4. On the View ribbon, turn off Top and Bottom Parts (outlines) to hide them. 

5. Choose Design > Stencil Designer. There are two modes of using Stencil Designer: 

 
Automatic – Create stencils from a library of stencil conversion history. 

Interactive – Select pads, flashes or footprints in the design and create stencils. 

In addition, use Library Manager to manage stencil libraries. 

6. For this sample, select Interactive. The Select Pattern and Creation Mode dialog 

appears. Use the dialog to set source layer for selection, mode of selection and 

creation mode. 
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7. Set Source Layer to Paste Mask Top and set Create Duplicate Layer option disabled. 

 

The Selection modes are: 

Select Pattern – interactively select pads or flashes, commonly in a pattern. 

Select Footprint – Select a footprint (if present) – must be sourced from a Top or 

Bottom Layer. 

Select Library – Select a stencil library item and create stencils that match its pattern. 

 

The Creation Modes are: 

Change Shape – change the shape of the selected pad or flash. 

Offset – keep the shape and shift the stencil shape off of the pad. 

Scale/Resize – keep the shape but shrink or grow its size. 

Heel and Toe – keep the shape and shrink the heel or toe (For PLCCs, SOICs, etc.) 

 

8. Set Selection Method to Select a Pattern and set Creation Mode to Change Shape. 

The source layer is set to the active and only visible layer. 

9. In the upper left corner of the board, area select the 4 pin oscillator pattern and press 

right mouse button to accept the selection. The pattern is highlighted. 

 

    
 

 

10. Click right mouse button to accept the selection. Click OK to start stencil creation. 

The Stencil Design dialog appears in Change Shape Mode. 

 

The Stencil Design dialog is comprised of two sections. The first area is for selection of the target 

layer for new stencils. You can choose to create a new layer, or add to an existing Paste Mask 

layer. 
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11. For this example, choose New Layer and accept the default name. 

 

The second area is where you define the new shape and preview the stencil design before you 

create it. Initially, change shape mode presents a stencil shape identical to the selected pattern. 

Use the settings to change the shape. 

 
 

12. Change the shape from Rectangle to Diamond. 

13. Compensation is for enlarging or shrinking the shape. Set Symmetrical 

Compensation to -5.0 mil (shrink). 
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14. Saving to a library is optional. However, it does allow you to reuse stencil design 

content across designs with similar patterns or footprints. Use Save to Library to 

preserve this definition for use on another design. Enter a Stencil Name and 

optionally a Note. 

15. Be sure Internal Library is selected as the target library. Click OK to close the Library 

Save dialog. The stencil definition is saved to the internal stencil library. 

 

 
 

16. In the Stencil Designer dialog, choose Create. The Stencil is created and added to the 

new stencil layer. 

17. In the layers pane, double click the new Stencil_1 layer to view the new stencil. Select 

the Paste Mask Top layer to make it visible also. 

18. Experiment on your own with making pattern selections and using the three other 

creation modes to create stencils. 
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EXAMPLE B – In this example, you will use the new Stencil Designer to create stencils for a 

design using the change Automatic creation mode. 

1. In CAM350 choose File > Open. Do not save your last opened file. 

2. Browse to and select the demo file DST Demo 2018.cam from the Demos folder. 

3. In the Layers Display pane, double click the Paste Mask Top layer to make it the 

only visible layer. 

4. On the View ribbon, turn off Top and Bottom Parts (outlines) to hide them. 

5. Choose Design > Stencil Designer.  

 
6. Choose Automatic. The Stencil Designer Automatic Creation dialog appears. 

7. This dialog has four sections. The source layer selection, target layer selection, stencil 

library source selection and stencil library processing area. 

8. As in the previous example, set Source Layer to Paste Mask Top and enable New 

Layer as the target layer and leave the default name of Stencil_1. 

9. In the Library area, select External Library. The Open Library dialog appears. 

10. Browse to and select the demo library dst demo.dststlib and click Open. This loads 

the external library and presents them in the Library Contents column. 

11. Each item in the library is a previously created stencil. It is possible some or all of 

these stencils can be used for this design. Choose Add All to add all library items to 

the column of stencils to process. 

12. Click Create. The matched stencil library entries are compared to the design and if 

the patterns match, a stencil is created for each match. 
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NEW AUTO LAYER ALIGN 

Use new automated layer alignment features to align all layers and external netlist during 

automated import. Alternatively, use the new alignment commands to align content post import. 

 

EXAMPLE A – In this example, we will automatic import a collection of misaligned Gerber, NC 

Drill and external netlist files and use the new interactive features to align them all. 

1. Start CAM350 and choose File > Import. 

2. Choose Automatic Import. 

3. Browse to and select the layer_offset folder. 

4. At the bottom of the page there are options to align layers and external netlist. Ignore 

those for the moment. We will use them in a later step. 

5. Set the AutoImport Template to PADS General Template 

a.  
 

6. Set AutoImport Templates to PADS General Template. 

7. For the purpose of this sample, we will skip the remaining pages. Click Finish. 
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8. Click No to decline Netlist Extraction. 

9. When the imported content is viewed, you will note all layers were imported with 

variable origins and as a result are all misaligned. 

 

a.  
 

10. On the Tools ribbon, select Auto Align Layers. All imported layers and external netlist 

are aligned to a common origin. 

11. On the View Ribbon, select Zoom All (or press Home). 

12. Choose File > New to clear the imported data and do not save the file. 

 

EXAMPLE B – In this example, we will automatic import the same collection of misaligned 

Gerber, NC Drill and external netlist files and use new automated features to align them all. 

1. In CAM350, choose File > Import. 

2. Choose Automatic Import. 

3. Browse to and select the layer_offset folder. 

4. At the bottom of the page there are options to align layers and external netlist. Enable 

Align Layers. We will align the netlist in a later step. 

5. Set the AutoImport Templates to PADS General Template. 
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6. For the purpose of this sample, we will skip the remaining pages. Click Finish. 

7. Click No to decline Netlist Extraction. 

8. When the imported content is viewed, you will note all imported layers are aligned 

to a common origin. 

9. On the Analyze ribbon, select Netlist Tools > Align External Netlist. The external 

netlist is aligned to the common design origin. 

 

 
NEW CADENCE ALLEGRO INTERFACE 

Use the new Cadence Allegro Interface to initiate a new CAM350/DFMStream session directly 

from the Allegro menu. When selected, an IPC-2581 file is extracted from Allegro, a new session 

of CAM350 started and the file imported into CAM350. Additionally, crossprobing between 

CAM350 and Allegro is initiated. 

 

EXAMPLE A – In this example, we start with a design in Allegro, initiate a new session of 

CAM350, and initiate crossprobing with CAM350. 
1. Open “Doc Editor Demo.brd” in Cadence Allegro. 

2. In Allegro, select Tools > New CAM350 Design File. The New CAM350 Design dialog 

appears. 

3. Accept the default path and filename for the IPC-2581 file, leave other options disabled 

and click OK to proceed. 

 
 

After a few moments, the IPC-2581 is extracted and CAM350 is started. In addition, the data is 

imported into CAM350 and the System Integration dialog opens with Allegro crossprobing 

enabled. 
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4. Double-click the Top layer to make it the only visible layer in CAM350 and note how the 

layer display updates identically in Allegro. This is an example of the crossprobing 

features. 

 

EXAMPLE B – In this example, we start with a design in Allegro, initiate a new session of 

CAM350, and initiate crossprobing with CAM350. In addition, a custom DFM analysis stream 

will be derived from the current allegro constraints, and if present, constraint areas. You will then 

run a DFM Analysis usingthe stream, select analysis errors and crossprobe back to Allegro to see 

the error location there. 
1. Open “Doc Editor Demo.brd” in Cadence Allegro. 

2. In Allegro, select Tools > New CAM350 Design File. The New CAM350 Design dialog 

appears. 

3. Accept the default path and filename for the IPC-2581 file. 

4. Enable the Create DFM analysis stream from PCB Editor constraints option. 

5.  Click OK to proceed. 

 
 

After a few moments, the IPC-2581 is extracted and CAM350 is started. In addition, the data is 

imported into CAM350 and the System Integration dialog opens with Allegro crossprobing 

enabled.  You will run the custom DFM stream analysis. 

1. Click OK to proceed. 
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2. Once CAM350 is started and crossprobing initiated, choose Analysis > Streams Editor. 

The Streams Editor pane opens. 

3. The list of Active Streams will contain two streams. The first Stream titled as Stream 0 is 

the default stream. The second stream titled as Doc Editor Demo is the custom DFM 

Stream. 

4. Select the custom stream and note the last two checks. These are custom outer signal 

layer and inner negative plane checks derived from design data in Allegro. 

5. Uncheck Run for Signal 1 and Negative 0 checks to skip these checks that are duplicates 

of the custom check. 

6. Select Run Selected > Inside Board Outline Only to initiate the analysis. Several errors 

should be detected. Choose OK to Switch to Error Explorer. 

7. Close the Stream Editor Pane. 

8. Arrange the Allegro and CAM350 applications on your display so that both are visible 

and sharing screen space. 

9. In Error Explorer, select any error in the list and note the reaction of Allegro and 

CAM350 to center the view in both applications on the selected error. Also note the 

addition of a CAM350 specific error marker in Allegro. 

 

 

NETLIST COMPARE ENHANCEMENTS 

New features were introduced to aid in the exploration of netlist compare errors. Enhancements 

were made to both Error Explorer and the display of nets involved in netlist compare errors. 

 

EXAMPLE – In this example, you will open a design that contains netlist errors and use the new 

features to explore the errors. First, let’s review the new options for external nets and netlist 

compare. 
1. Start CAM350 and Browse to and open the open-shorts.cam file. 

2. Choose Home ribbon > Options. 

3. Select Editors > CAM Editor options. 

4. Scroll down until External Nets options are visible. 

 

Here you will note the addition of viewing inner net points in support of newer ODB++ and IPC-

2581 netlist standards. Additionally, the default graphics and colors for net points have been 

updated. 
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5. Select Editors > Streams Editor options. 

6. Scroll down until the new Netlist Compare Error Viewing options are visible. 

 

 
 

These new options were added to facilitate improved exploration of netlist compare errors. When 

you select a netlist error in error explorer, the display is temporarily updated until the error is 

unselected. The display of nets involved in an error is determined by three new options. 

Use transparency – make all non-involved nets transparent. 

Hide nets not involved in a selected error – hide all non-involved nets. 

Use custom colors – replace current layer and highlight colors for involved nets with the 

assigned colors. 

7. Select Cancel to close the Options dialog without making changes. 

8. Select the Nets pane to make it active and note the addition of a Show column to control 

visibility of individual CAM nets. 

9. On the Nets pane choose View Nets > Hide All Nets. This hides all design elements that 

belong to a CAM net. Note the presence of some partial net data. These pins are not 

associated with any CAM net. 

10. On the Nets pane choose View Nets > Hide No Net Elements. The remaining elements 

are hidden. 

11. On the External Nets pane, use View Nets to toggle the display of all external nets to 

Hide and then back to Show. Leave all external nets visible. 

12. On the Nets pane choose View Nets > Show All Nets and uncheck Hide No Net 

Elements. All net and no net elements are made visible again. 

 

Now let’s experiment with the usage of these new options. 

1. On the Analysis ribbon, choose External Nets. 

 

There are changes to the CAM Netlist Extract options as highlighted below. The Assign Negative 

plane as single point net was removed. It was no longer necessary. A new Post Extraction option 

was added to overwrite CAM net names with external net names. This should be used whenever 

Net Bridges are present in your design. It will preserve external net name associations with the 

net bridges. 

 



 

 

DownStream Technologies, LLC.,                              Copyright © 2006-2024                             14 of 23 
 

 
 

2. Disable Compare Against External IPC-D-356 Netlist File option. 

3. Leave the remaining options unchanged and choose Run Now > Inside Board Outline 

Only. After a few moments, you are prompted that errors were found. Choose OK to 

make the Error Explorer pane active. 

4. Close the External Nets pane. 

5. In the Error Explorer pane, click error ID 0 to choose the first error in the list. Note how 

the display changes to use the custom color option. 

6. On the Error Explorer pane, choose Use Custom Colors again to restore the previous 

state. 

7. On the Error Explorer pane, choose Hide Uninvolved Nets and note how all nets 

disappear except those involved in the net. 

 

 
 

                          Hide/Show Uninvolved Nets                   Toggle Custom Colors 

     Toggle Transparency 

 

8. On the Error Explorer pane, choose Hide Uninvolved Nets again to restore the previous 

state. 

9. On the Error Explorer pane, choose Use Transparency and note how all nets are 

transparent except those involved in the net. 

10. On the Error Explorer pane, choose Use Transparency again to restore the previous state. 

11. Another improvement is the ability to zoom to a net involved in a netlist compare error. 

For the first error, click each individual hyperlinked CAM net name and External Net 

name. Note how the display is updated to show the selected net. 
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DESIGN COMPARE ENHANCEMENTS 

New features were added to Design Compare to expedite the compare process. Enhancements 

include automated alignment of the designs to compare and simplified layer mapping. In 

addition, Design Compare is now available as a licensed option that can be added to lower level 

CAM350 configurations. 

 

EXAMPLE – In this example, you will open a design and compare it against another design and 

use new automatic design alignment and improved layer mapping features. 

1. Start CAM350 and open the DST Demo 2018.cam file from the Demos folder. 

2. On the Analyze ribbon, choose Design (Compare). The Design Compare pane appears. 

3. Note the new Align to Local Design Origin option. For the purpose of this training, 

disable the option. 

 

 
 

4. In the Import Design to Compare, choose Browse and browse to and select the DST 

Demo 2018 gerber.cam file from the same folder as the previously opened file. 

5. After a few moments the design is opened and you will clearly see the design origins are 

different as evidenced by the board outline of the design in memory overlayed over the 

newly opened compare design. 

 

 
 

6. Choose Delete Imported Design to purge the imported design from memory. 

7. Enable the Align to Local Design Origin option and click Load. The design is loaded, 

but now the design is aligned to the local design origin. 
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Improvements were also made to layer mapping to make it easier to map layers for comparison 

between designs to compare. 

1. Scroll down the Design Compare pane until the layer mapping area is fully visible. 

Hint: You may have to expand the size of the pane. 

2. Note the new layer mapping preference choices of Layer Name, Layer ID or Layer Type. 

 

 
 

These options are design to make layer mapping more expedient. In this design compare 

example, Layer type mapping does not work for all layers because of the variance in layer type 

assignment per design. 

3. Scroll vertically the list of layers to map until you reach the top of the list. The default 

option is to map by layer type. Note that some, but not all layers are mapped. This is 

because the designs to compare did not have identical layer type. 

4. Choose Map Layer by Layer ID. Note how the layer mapping instances improve 

somewhat, but the mapping is not correct because of differences in layer order. 

5. Choose Map Layer by Layer Name. Note how the layer mapping is now empty because 

there are no matches between layer names in the designs to compare. 

6. Choose Map Layer by Layer Type and we will use other features to map mismatched 

layers. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

DownStream Technologies, LLC.,                              Copyright © 2006-2024                             17 of 23 
 

CAM350 7.0 CUSTOMER DEFECT FIXES AND ENHANCEMENTS 

 

CAM350 15.0 BUILD 2075 DEFECT FIXES 

 
73149 CAM350 DXF import – issue handing elliptical arcs corrected 

73113 CAM350 DFM error count incorrect on certain designs due to a change in how 

CAM350 generates vias for padstacks.  This was corrected. 

73091 CAM350 Import DXF – This file imports with incorrect Dcodes and the re-export 

of DXF or Gerber results in unnecessarily large files 

73077 CAM350 fails when importing this DXF file 

73071 CAM350 fails when importing this ODB++ design 

 

 

CAM350 15.0 BUILD 2067 DEFECT FIXES 

 
72999 CAM350 15.0 Netlist Compare navigation features not working properly 

72981 The older CAM350 macro language does not report Stream Errors 

72979 When user deletes a layer, errors referring to layer should be removed as well 

72971 Auto Detect Text Areas fails on this design 

72943 DFM Analysis – Backdrills that are internal to the stackup are not being found 

during drill to copper checks 

72924 Stencil Designer – Footprint is not available until the file is saved and reopened 

72863 Mill Tab import failure 

72860 CAM350 API – various defects and enhancements:   

72859 DXF Import – Full circles imported as half circles for this DXF 

72856 CAM350 API – Enh to Pause and Resume script playback 

72855 CAM350 API – Enh to force redraw during VB script playback 

72854 CAM350 API – CAM350 12.2 DXF Import dialog incorrectly appearing in 15.0 

72851 Wheel Mouse Panning is different in CAM and World views 

72846 CAM350 15.0 Japanese UI text corrections 

72836 ODB++ Import – precision issue 

72815 Draw to Flash – Interactive any-angle misses some rotated pads 

72811 Draw to Flash – Conversion results in oddly rotated flashes for this design 

72805 Draw to Flash – Fails to convert pattern when selected after a previous pattern 

conversion 

72558 Analysis – Copper spacing check fails to find unplated drills shorted to copper on 

this design 

72510 DXF Export – Failure on mirrored CAM350 data 

72715 Panel Editor – panel exported to gerber and reimported has data inverted 

72706 Circle Mill Paths – Incorrect display using OpenGL 

72098 Custom Apertures:  Pad Mask to Pad Ration failure 
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CAM350 15.0 BUILD 2059 DEFECT FIXES 

 
72797 ODB++ Import – Copper voids missing after import for this Altium design 

72787 Regression -  File SaveAs sets the wrong CAM version in the CAM file. 

72784 IPC2581 import missing internal pads for this design 

72782 IPC2581 Import does not correctly mirror padstack element instances 

72781 IPC2581 import failure on this Zuken CR8000 design with slot cavity 

72774 API macro playback improvement for drill import 

72749 Drill to Flash using “any angle” is missing some angles 

72743 Install - DisableEnv not Getting Set Properly in CAM350 ini file 

72742 ODB++ import failure for this design 

72728 Stencil Designer – layer is sometimes not visible in this design 

72718 DXF import failure for this design 

72698 Stencil - Patterns being applied to previously completed pattern 

72670 New Cadence interface improvement if there is data loaded already in the 

associated CAM350 window 

72663 IPC-2581 import problem 

72596 Oblong pads dropped on netlist extract 

 

72542 Automatic mode in Stencil designer should sort with the highest "pin" (or pad) 

count to the top 

71948 This design displays incorrectly using OpenGL  

70895 ODB++ import - Pad lost 
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CAM350 15.0 BUILD 2053 DEFECT FIXES 

 

Defect Description 

  

72658 Mill Circle – Add Mill Circle only adds ½ circle 

72656 Allegro – CAM350 interface ODB++ does not work for filenames with embedded 

spaces 

72654 Extra pad causing shorts in this IPC2581 rev C file from Allegro.   

72630 CAM350 15.0 Wizard Cancel does not work 

72595 Licensing updates for new 15.0 features 

72591 Auto Save - Auto Options not working as expected 

72581 File Open - Change default Database not recognized 

72577 Allegro DXF incorrectly imported 

72569 Stencil - Remove Mirror Settings for all Stencil Shapes 

72566 Stencil - Internal Library list populated with External Library list 

72564 Stencil - Remove Commands from Create Stencil From Library Item Dialog 

72563 Stencil - Change Save to Library Buttons to Save, Close and Cancel 

72562 Stencil - Add Prompt for Overwrite on Save To Library 

72560 Stencil - DogBone Aperture (MELF/CPAD from Stencil) not visually correct in 

OpenGL 

72556 OpenGL display is incorrect for pads display on this design 

72529 OpenGL graphics are incorrect after Mirror Vertical operation 

72539 Stencil - Change Shape to Thermal Leads to Crash 

72538 Annular Ring - Minor Text UI Issue 

72535 Stencil - Field Editing in non-units fields has unintentional cursor movement 

 

72550 Align Netlist - ScreenTip on External Netlist is incorrect 

72515 DXF – Failure on export for this design 

72512 DXF – Import in append mode 

72510 DXF Export fails on mirrored CAM350 data 

72500 Failure in Draw to board outline 

72494 ODB++ import misses PADS offset on this design 

72493 Stencil - Interactive Select Library not Working 

72488 Design Compare – File no longer allows mapping changes after Save 

72478 Object snap does not work in Add Part command for CAM350 15.0 

72473 ODB++ import - failure for rare data situation 

72468 Issues when trying to create a d-pack from this data 

72462 Cross Probing - PADS Layout and Xpedition - reconnect fails after Streams execution 

72461 Enhancement to Via and Backdrill Templates – symmetric column creation should 

not align vias in adjacent layers 
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72460 Backdrill Stackup template drawing elements shift on execution 

72448 Stencil - When you have one layer turned on before going into Stencil creation mode, 

it should default to that layer in the pulldown.  

72469 Gerber Export default decimals should be 5 

72462 CrossProbing for PADS and Expedition reconnect failure after Streams execution 

72426 Enhancement to make ODB++ import (panel dialog) resizeable 

72418 Stencil - DogBone aperture created with wrong shape for some parameters 

72399 Mill Tab - Addition of Perforation to Mill Tab does not update Mill Tabs in Design 

72394 PADS Import - incorrect component outline due to extremely small text height 

72244 Stencil kit – Heel and Toe Settings not applied correctly to some pin patterns 

72231 Design with rout compensation is incorrectly merged when imported with the 

merge cmd 

72218 ODB++ Import - Drill layers missing on import for this old design file 

72205 Auto Align - Auto Align Command Missing ScreenTip 

72089 Enhancement to Pass parent PID for BluePrint and CAM350 to Winwrap 

BasicIDE.exe on command line for custom menu commands 

72082 DXF import – some lines dropped on this DXF file 

72069 Compare Results multiple selection is not working properly 

72049 Print does not work on this design with duplicate layer names and layer types 

72045 CAP library Delete all 

71949 VB Recording - script is incorrect for adding layer sets 

71854 IPC-2581 Rev C import does not support updated SlotCavity element 

71799 Mill Data in merged databases displays incorrectly when using OpenGL 

71641 ODB++ Import and then Save does not work for this design 

71571 PADS Layout .REP files should not be selected for RS274X Gerber files 

71545 OGL display issue with Mill Data on this design 

71482 Component outline color is not displayed in OGL for this design 

71353 SUV header column cleanup for usability 

71352 Layer labels cleanup in the Stackup Preview window so they are not truncated 

71345 SUV - Context menu commands in the Stackup Table disable the table 

71335 SUV - Refresh issue on SUV grid in Autoimport mode when scrolling horizontally 

71158 DXF Import - TTF fonts does not match AutoCAD size and position 

70911 Enhancement to Query External Net - report layer and location for external net point 

70623 IPC-2581 import - layer mapping for ALL LAYERS stackup not initialized 

70514 Compare layers not working on this design data, but worked in CAM350 12.2 

70421 Japanese version only - Negative Plane check does not work in DFM for this design 

70404 VB Automation samples added to installation 

70341 New Paste Mask spacing check to soldermask opening without paste 

70310 File Auto Import command does not work for this design 

70309 Macro Recording - Recording and execution of Streams Analysis does not work  

70218 Auto hide stops working in error explorer after answering dialogue  
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70179 OpenGL display issue - Test points and Probes not visible for this design 

70157 Clarification in user interface for "Paste Mask to Copper" check 

70148 Bad mapped drive on PC causes CAM350 File open delay 

70141 Streams paste checks not working on bottom paste only checks. 

70099 IPC-2581 import - Invalid REV C warnings for IMPEDANCE and LogicalNet 

SPECREF definitions 

70082 This old CAM database gets no results in streams 

70043 Problem import Mill Data for this design 

70010 DXF import - Failure, but works in earlier releases 

69967 Cannot import stackup XML for this design 

69934 Rename Layer - Usability improvement to to highlight old name  

69924 Pad shift on netlist extract 

69893 Draw to Flash behaves differently on different data types  

69870 GerberX3 import improvement 

69869 Route file will not load during autoimport, but loads via import nc mill data 

69868 Gerber Import - arcs incorrect after import for this gerber 

69855 IPC2581 import - failure, but imports in CAM350 12.2 with warning messages 

69821 Draw to Flash failure on this data 

69814 DFM Stream - Mask to Via check ignores layer stackup 

69794 CAMSettings Import failure 

69713 Draw to Flash - failure on this design with rounded shapes with small cuts in them 

69568 DXF IMPORT support for version AC1032 - AutoCAD 2018,2019,2020 

69567 ODB++ import - PAD dropped on layer signal_1 for this design 

69549 CAM350 language versions – “Streams Errors Listed” must be in English text 

69510 NC data with negative tool size 

69324 CAP Editor - Edit features do not work if invoked from Panel Editor 

69303 VB Script - Record and Playback for PCB Images table in Panel Editor incorrect 

69232 Custom tools do not allow path specification for arguments and starting directory 

69268 Export Gerber gives Web Browser ActiveX warning message 

69214 Start Page links should bring up default browser, but always try to invoke IE right 

now 

69154 Import Altium ODB++ - "the parameter is incorrect" on netlist compare 

69000 Gerber to Mill (Panel) failure on this design 

68941 Add Polygon - Hatched pattern preview does not match results 

68921 Layer Compare fails on this design 

68751 Enhancement to support Embedded Test Points support 

68642 Mill Tab – BluePrint Conversion of Mill Tab to CAM350 is not Correct 

68596 GerberX3 import improvement 

68510 AutoImport failure 

68464 Layers Pane - Disable of Auto-renumber does not work 
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68316 Streams VB execution results in different error count on playback 

68091 Nelist Compare enhancement to cover unplated drills, drill slots and mill paths 

67603 Draw 2 Flash not working correctly 

66025 DXF import - Failure on this DXF with hatches 

65514 Measure enhancement to add more info such as drill or pad size 

65440 Composite to layer failure 

64714 Auto-import - Multiple layer type assignment problems. 

62733 Draw to Flash - Interactive does not work on circle 

56294 Improve layer mapping in design compare 
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HOW TO CONTACT 

 

Please send any defects, feedback or questions to support@downstreamtech.com.     

 

 

PATENTS, COPYRIGHTS, AND TRADEMARKS 

 

PATENTS 
“AUTOMATED PCB MANUFACTURING DOCUMENTATION RELEASE PACKAGE SYSTEM 

AND METHOD”, United States Patent No. 7,409,666 B2 

“ADAPTIVE TEMPLATE SYSTEM FOR AN AUTOMATED PCB MANUFACTURING RELEASE 

PACKAGE SYSTEM”, United States Patent No. 8,875,072 B2 

 

COPYRIGHTS 

Copyright© 2005-2024 by DownStream Technologies, LLC.  All rights reserved.   

This information is copyrighted; all rights are reserved by DownStream Technologies, LLC.  This 

information may not, in whole or in part, be copied, photocopied, reproduced, translated or 

reduced to any electronic medium or machine-readable form without the express written 

permission of DownStream Technologies, LLC. 

DownStream Technologies, LLC, 290 Donald Lynch Blvd, Suite 300, Marlborough, Massachusetts 

01752 

Mimalloc is a Copyright © of Microsoft Corporation 2018-2021.  CAM350 uses Microsoft’s 

Mimalloc general purpose memory allocator, written by Daan Leijen.  Mimalloc is available to 

any interested party under the MIT license.  

 

 

TRADEMARKS 

BluePrint  , BluePrint-PCB  , BluePrint for Printed Circuit Boards  , and CAM350 are registered 

trademarks of DownStream Technologies, LLC.  Adaptive Templates™ is a trademark of 

DownStream Technologies, LLC.   Adobe, Adobe PDF Library, Adobe logo, Acrobat, PostScript, 

and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated. 

The Postscript language is copyrighted by Adobe Systems Incorporated. DXF and Autodesk are 

registered trademarks of Autodesk, Inc. FLEXlm is a registered trademark of Macrovison 

Corporation.  Omnify is a registered trademark of Omnify Software.  Microsoft, Windows, 

Microsoft Paint, Microsoft Word, Microsoft PowerPoint, Microsoft Excel are either registered 

trademarks or trademarks of Microsoft Corporation. All rights reserved.  HOOPS is a registered 

trademark of TechSoft3D.    

All other trademarks or registered trademarks are the property of their respective owners. 

We have done our best to ensure that the material found in this publication is both useful and 

accurate. However, please be aware that errors may exist in this publication, and that neither the 

authors nor DownStream Technologies, LLC make any guarantees concerning the accuracy of the 

information found here or in the use to which it may be put. 
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